[Gc] Build-Error: "configure: error: yes is an unknown thread package"

Linuxhippy linuxhippy@web.de
Mon, 09 Dec 2002 15:54:23 +0100


Hi GC-Folks!

When I tried to build gc6.1 with --enable-threads on my SuSE-Linux8.1 
installation it says "configure: error: yes is an unknown thread package".
I tries to build it using the builting gcc-3.2 and the ditro itself is 
using Linux-2.4.19.
Does anybody know how to solve this problem?

And, I hope I dont bore proffesionals like you, but I like the idea of a 
gc-lib  for C++ so much, thats a must for me to know as much as possible.

1.) How easy (hard) is it to cause the gc to leak.
I want ask this, because even in Java without any (noteable) pointers t 
was under special circumstances possible to cause the very good sun-gc 
to leak.
I expect that C++ is harder to gc than Java.....

2.) How can I build the lib for i386?
Im not very experienced using gcc. Is it enough if i set CFLAGS="-O2 
-march=i386" is it than compilied for i386?
Do you know any god optimisations that reduce size and are not so bad 
for performace?

3.) When is memory not GC-able?
Are widgets, windows, etc. also gc-abe?

Last but not least I want to thank everybody who made it possible that 
this great garbage-collector is free, this makes me possible to use it 
for my own gpl-preject.
Thanks for doing such great stuff!!

Mfg Linuxhippy