[Gc] autoconf on 6.3/6.4

Boehm, Hans hans.boehm at hp.com
Fri Jan 28 17:33:13 PST 2005


Look at version.h in the main directory.  It defines GC_VERSION_MINOR.

By default, it also declares and initializes GC_version.  The
file is included by exactly one of the GC library files (which is ugly,
but ...).  Thus you should just be able to link against the library
and test GC_version.

Hans

> -----Original Message-----
> From: gc-bounces at napali.hpl.hp.com
> [mailto:gc-bounces at napali.hpl.hp.com]On Behalf Of MenTaLguY
> Sent: Friday, January 28, 2005 5:22 PM
> To: GC Mailing List
> Subject: [Gc] autoconf on 6.3/6.4
> 
> 
> Is there any way to distinguish between 6.3 and 6.4 for the 
> purposes of
> an autoconf test?  (for example, an API change?)
> 
> -mental
> 


More information about the Gc mailing list