[Gc] Re: Does thread support work for the windows 7.0 version?

Achilleas Margaritis axilmar at otenet.gr
Tue Dec 18 03:47:52 PST 2007


Thanks everyone.

I grabbed the version from CVS and it works fine.

Boehm, Hans wrote:
> IIRC, this was an initialization issue?
> 
> If so, this patch has been in the CVS tree for a while, but it is not in 7.0.  But my recollection is that this primarily shows up with static constructirs that allocate before the GC_INIT call?
> 
> Hans
> 
>> -----Original Message-----
>> From: gc-bounces at napali.hpl.hp.com
>> [mailto:gc-bounces at napali.hpl.hp.com] On Behalf Of Achilleas
>> Margaritis
>> Sent: Sunday, December 16, 2007 2:28 AM
>> To: gc at napali.hpl.hp.com
>> Cc:
>> public-gc-o/PNRNCSakrWxDs0y9d3MAC/G2K4zDHf at ciao.gmane.org;
>> Achilleas Margaritis
>> Subject: [Gc] Re: Does thread support work for the windows
>> 7.0 version?
>>
>> O/H Christophe Meessen έγραψε:
>>> Hello,
>>>
>>> I reported a bug in 7.0 with a hack solving the issue. Hans
>> Boehm then
>>> sent back a patch on the list to properly solve the bug.
>> But he said
>>> he could not check if it solved the bug.
>>>
>>> Does the gc library you use include this patch ?
>>>
>>> The symptoms you report are similar to the one I saw
>> myself. It worked
>>> well in single threaded mode and failed as soon as another thread
>>> comes into play. Check this first.
>> No, my gc library does not include this patch.
>>
>> Where can I get it? I searched the web but with no luck.
>>
>>
>> _______________________________________________
>> Gc mailing list
>> Gc at linux.hpl.hp.com
>> http://www.hpl.hp.com/hosted/linux/mail-archives/gc/
>>



More information about the Gc mailing list