[Gc] Re: Desperately needing GC 7.1

Manuel.Serrano at sophia.inria.fr Manuel.Serrano at sophia.inria.fr
Mon Jan 14 19:58:50 PST 2008


If time permits before the official 7.1 is unleashed, I have two additional
remarks concerning the 7.1 alpha2. The first one in this mail, the second 
one in the following...

 1- In order to use Makefile.direct with 7.0 and 7.1 and MacOS X 10.5 on x32
    computers, I have had to add manually the compilation option:

      -DHAS_X86_THREAD_STATE32___EAX

    This was not needed on 10.4.

 2- A Bigloo user has reported that Makefile.direct does not work with icc
    on Linux. I have not had the time to investigate myself, I will 
    as soon as possible.

I don't know if you wish to maintain Makefile.direct but I hope you
will because using autoconf, automake and, libtool might be a true
headache. I have for instance failed to use these tools for Bigloo because
the compilation needs to bootstrap the compiler and thus it needs to
use the libraries, including the GC, before installing them. I'm not
knowledgeable enough to do this decently with libtool.

In addition, I'm a little bit concerned about the portability, in a
broad sense, of these tools (for instance, what about MacOS Xcode or
Windows VisualStudio).

Cheers,

-- 
Manuel


More information about the Gc mailing list