[Gc] Re: What version of Boehm for --enable-objc-gc ?

Andrew Pinski pinskia at gmail.com
Fri Apr 24 07:22:13 PDT 2009


On Fri, Apr 24, 2009 at 7:20 AM, Andrew Haley <aph at redhat.com> wrote:
> Fabrice Feray wrote:
>
>> What version of Boehm's gc is best fit for the objc runtime? It seems
>> that the one that comes with gcc is a special version meant for java. Am
>> I wrong?
>
> It's not substantially customized for Java, although it has some hooks that
> make it work better on Java.  I don't think there's any reason not to use
> it for Objc.
>
> Maybe someone on the GC Mailing List has more info, but I think that's right.


in fact recent versions of gcc, turn on the in tree version for use
with libobjc also.

--Pinski



More information about the Gc mailing list