[Gc] Re: boehm-gc breakage between binutils 2.16.1 and 2.17 on FreeBSD [7.2]

Ludovic Courtès ludo at gnu.org
Tue Sep 1 00:54:01 PDT 2009


Hi,

Loren James Rittle
<rittle at latour.labs.mot.com> writes:

> +# if (defined(FREEBSD) && __FreeBSD__ >= 7)
> +/* On the FreeBSD system, any target system at major version 7 shall    */
> +/* have dl_iterate_phdr; therefore, we need not make it weak as above.  */
> +#define HAVE_DL_ITERATE_PHDR
> +#endif

Is there any reason not to use `AC_CHECK_LIB([dl_iterate_phdr])' for
this?  This would be more reliable and "future-proof".  (I understand
this was already done this way before your patch.)

Thanks,
Ludo'.



More information about the Gc mailing list