Re: [Gc] optional namespace for gc_cpp

Ivan Maidanski ivmai at mail.ru
Wed Oct 10 13:12:18 PDT 2012


Hi Alexander,

Could you please fix and improve your patch so that I could commit it to v7.3?
1. Fix test_cpp.cc to make it compilable with -DGC_NAMESPACE
2. "//#pragma message ..." - I think it should be removed
3. Rename QUALIFY to GC_NS_QUALIFY
4. Q: gc_cpp.cc requires no changes, right? 
5. Add commit log message

Thank you.

Regards,
Ivan

Tue, 09 Oct 2012 16:02:53 +0200 от Alexander Herz <alexander.herz at mytum.de>:
>	
>
>
	
	
>
		
		
			
>Hi,
>
>
I ran into some name clash problems with boehm c++ (somewhere a value 
>
called gc was defined).
>
>
As a fix I suggest to add GC_NAMESPACE define and the namespace boehmgc 
>
as outlined in the gc_cpp.h attached.
>
It's really a minor change (doesn't affect anything else but this header 
>
and it's optional). Would be nice to see it (or something similar) in 
>
the official version.
>
>
Regards,
>
Alex
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://napali.hpl.hp.com/pipermail/gc/attachments/20121011/2f4be900/attachment.htm


More information about the Gc mailing list