[httperf] --wlog wont work

McliffordIE@aol.com McliffordIE@aol.com
Mon, 8 Dec 2003 08:05:23 EST


-------------------------------1070888723
Content-Type: text/plain; charset="US-ASCII"
Content-Transfer-Encoding: 7bit

Hi,

I'm also having problems using the --wlog option as posted to the list in 
September-
but I havent seen any reply posted.

As you can see from these two examples, the request works fine if I specify 
the uri as part of the 
command line (--uri )

Then, when I attempt to request the same page via --wlog, I just get  http 
400 errror (Bad Request)

Any help/insight would be very much appreciated.

Running httperf-08  on RedHat 7.2.

Thanks,
Mike


./httperf --server MYSERVER
           --port 1065 
           --uri=/portal/index.html 
           --debug=1 
           --print-request=header 
           --print-reply=header


httperf --print-reply=header --print-request=header --client=0/1 
--server=MYSERVER --port=1065 --uri=/portal/index.html --send-buffer=4096 --recv-buff
er=16384 --num-conns=1 --num-calls=1
SH0:GET /portal/index.html HTTP/1.1
SH0:User-Agent: httperf/0.8
SH0:Host: MYSERVER
SH0:
SS0: header 87 content 0
RH0:HTTP/1.1 200 OK
RH0:Server: Netscape-Brew/6.3
RH0:Date: Mon, 8 Dec 2003 12:45:29 GMT
RH0:Content-Language: en
RH0:Cache-Control: no-cache
RH0:Cache-Control: max-age=0, must-revalidate
RH0:Pragma: no-cache
RH0:Transfer-Encoding: chunked
RH0:Connection: keep-alive
RH0:Keep-Alive: timeout=30,max=4
RH0:Content-Type: text/html;charset=ISO-8859-1
RH0:
RS0: header 316 content 11045 footer 2
Maximum connect burst length: 0

Total: connections 1 requests 1 replies 1 test-duration 0.335 s

Connection rate: 3.0 conn/s (335.3 ms/conn, <=1 concurrent connections)
Connection time [ms]: min 335.3 avg 335.3 max 335.3 median 335.5 stddev 0.0
Connection time [ms]: connect 98.2
Connection length [replies/conn]: 1.000

Request rate: 3.0 req/s (335.3 ms/req)
Request size [B]: 87.0

Reply rate [replies/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)
Reply time [ms]: response 131.4 transfer 105.7
Reply size [B]: header 316.0 content 11045.0 footer 2.0 (total 11363.0)
Reply status: 1xx=0 2xx=1 3xx=0 4xx=0 5xx=0

CPU time [s]: user 0.11 system 0.23 (user 32.8% system 68.6% total 101.4%)
Net I/O: 33.3 KB/s (0.3*10^6 bps)

Errors: total 0 client-timo 0 socket-timo 0 connrefused 0 connreset 0
Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0



  

./httperf --server MYSERVER
          --port 1065 
          --wlog=y,pages.log 
          --debug=1 
          --print-request=header 
          --print-reply=header


pages.log   just contains this one line
===================
/portal/index.html
===================




httperf --print-reply=header --print-request=header --client=0/1 
--server=MYSERVER --port=1065 --uri=/ --send-buffer=4096 --recv-buffer=16384 --num-conns=1 
--num-calls=1
SH0:GET /portal/index.html
SH0: HTTP/1.1
SH0:User-Agent: httperf/0.8
SH0:Host: MYSERVER
SH0:
SS0: header 88 content 0
RH0:HTTP/0.9 400 Bad Request
RH0:Server: Netscape-Brew/6.3
RH0:Date: Mon, 8 Dec 2003 12:47:13 GMT
RH0:Content-Language: en
RH0:Content-Length: 86
RH0:Connection: close
RH0:Content-Type: text/html; charset=ISO-8859-1
RH0:
RS0: header 197 content 86 footer 0
Maximum connect burst length: 0

Total: connections 1 requests 1 replies 1 test-duration 0.197 s

Connection rate: 5.1 conn/s (197.0 ms/conn, 

-------------------------------1070888723
Content-Type: text/html; charset="US-ASCII"
Content-Transfer-Encoding: quoted-printable

<HTML><HEAD>
<META charset=3DUTF-8 http-equiv=3DContent-Type content=3D"text/html; charse=
t=3Dutf-8">
<META content=3D"MSHTML 6.00.2800.1226" name=3DGENERATOR></HEAD>
<BODY style=3D"FONT-SIZE: 10pt; FONT-FAMILY: Arial; BACKGROUND-COLOR: #fffff=
f">
<DIV><FONT face=3DVerdana>Hi,</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>I'm also having problems using the --wlog option a=
s posted to the list in September-</FONT></DIV>
<DIV><FONT face=3DVerdana>but I havent seen any reply posted.</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>As you can see from these two examples, the reques=
t works fine if I specify the uri as part of the </FONT></DIV>
<DIV><FONT face=3DVerdana>command line (--uri )</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>Then, when I attempt to request the same page via=20=
--wlog, I just get&nbsp; http 400 errror (Bad Request)</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>Any help/insight would be very much appreciated.</=
FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>Running&nbsp;httperf-08 &nbsp;on RedHat 7.2.</FONT=
></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>Thanks,</FONT></DIV>
<DIV><FONT face=3DVerdana>Mike</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>./httperf --server MYSERVER<BR>&nbsp; &nbsp; &nbsp=
; &nbsp; &nbsp;&nbsp; --port 1065 <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbs=
p; --uri=3D/portal/index.html <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp; -=
-debug=3D1 <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp; --print-request=3Dhe=
ader <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp; --print-reply=3Dheader<BR>=
</DIV>
<DIV><BR>httperf --print-reply=3Dheader --print-request=3Dheader --client=
=3D0/1 --server=3DMYSERVER --port=3D1065 --uri=3D/portal/index.html --send-b=
uffer=3D4096 --recv-buffer=3D16384 --num-conns=3D1 --num-calls=3D1<BR>SH0:GE=
T /portal/index.html HTTP/1.1<BR>SH0:User-Agent: httperf/0.8<BR>SH0:Host: MY=
SERVER<BR>SH0:<BR>SS0: header 87 content 0<BR>RH0:HTTP/1.1 200 OK<BR>RH0:Ser=
ver: Netscape-Brew/6.3<BR>RH0:Date: Mon, 8 Dec 2003 12:45:29 GMT<BR>RH0:Cont=
ent-Language: en<BR>RH0:Cache-Control: no-cache<BR>RH0:Cache-Control: max-ag=
e=3D0, must-revalidate<BR>RH0:Pragma: no-cache<BR>RH0:Transfer-Encoding: chu=
nked<BR>RH0:Connection: keep-alive<BR>RH0:Keep-Alive: timeout=3D30,max=3D4<B=
R>RH0:Content-Type: text/html;charset=3DISO-8859-1<BR>RH0:<BR>RS0: header 31=
6 content 11045 footer 2<BR>Maximum connect burst length: 0<BR><BR>Total: co=
nnections 1 requests 1 replies 1 test-duration 0.335 s<BR><BR>Connection rat=
e: 3.0 conn/s (335.3 ms/conn, &lt;=3D1 concurrent connections)<BR>Connection=
 time [ms]: min 335.3 avg 335.3 max 335.3 median 335.5 stddev 0.0<BR>Connect=
ion time [ms]: connect 98.2<BR>Connection length [replies/conn]: 1.000<BR><B=
R>Request rate: 3.0 req/s (335.3 ms/req)<BR>Request size [B]: 87.0<BR><BR>Re=
ply rate [replies/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)<BR>Repl=
y time [ms]: response 131.4 transfer 105.7<BR>Reply size [B]: header 316.0 c=
ontent 11045.0 footer 2.0 (total 11363.0)<BR>Reply status: 1xx=3D0 2xx=3D1 3=
xx=3D0 4xx=3D0 5xx=3D0<BR><BR>CPU time [s]: user 0.11 system 0.23 (user 32.8=
% system 68.6% total 101.4%)<BR>Net I/O: 33.3 KB/s (0.3*10^6 bps)<BR><BR>Err=
ors: total 0 client-timo 0 socket-timo 0 connrefused 0 connreset 0<BR>Errors=
: fd-unavail 0 addrunavail 0 ftab-full 0 other 0</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>&nbsp;</FONT>=20
<DIV><BR>./httperf --server MYSERVER<BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; -=
-port 1065 <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --wlog=3Dy,pages.log <BR>&=
nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --debug=3D1 <BR>&nbsp; &nbsp; &nbsp; &nbsp=
; &nbsp; --print-request=3Dheader <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --p=
rint-reply=3Dheader</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>pages.log&nbsp;&nbsp; just contains this one line<=
/FONT></DIV><FONT face 0 addrunavail 0 ftab-full 0 other 0</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>&nbsp;</FONT>=20
<DIV><BR>./httperf --server MYSERVER<BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; -=
-port 1065 <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --wlog=3Dy,pages.log <BR>&=
nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --debug=3D1 <BR>&nbsp; &nbsp; &nbsp; &nbsp=
; &nbsp; --print-request=3Dheader <BR>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --p=
rint-reply=3Dheader</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>pages.log&nbsp;&nbsp; just contains this one line<=
/FONT></DIV><FONT face=3DVerdana></FONT></DIV>
<DIV><FONT face=3DVerdana>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D</FONT></DIV>
<DIV><FONT face=3DVerdana>/portal/index.html</FONT></DIV>
<DIV><FONT face=3DVerdana>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D</FONT></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV>
<DIV><BR></DIV>
<DIV>&nbsp;</DIV>
<DIV>httperf --print-reply=3Dheader --print-request=3Dheader --client=3D0/1=20=
--server=3DMYSERVER --port=3D1065 --uri=3D/ --send-buffer=3D4096 --recv-buff=
er=3D16384 --num-conns=3D1 --num-calls=3D1<BR>SH0:GET /portal/index.html<BR>=
SH0: HTTP/1.1<BR>SH0:User-Agent: httperf/0.8<BR>SH0:Host: MYSERVER<BR>SH0:<B=
R>SS0: header 88 content 0<BR>RH0:HTTP/0.9 400 Bad Request<BR>RH0:Server: Ne=
tscape-Brew/6.3<BR>RH0:Date: Mon, 8 Dec 2003 12:47:13 GMT<BR>RH0:Content-Lan=
guage: en<BR>RH0:Content-Length: 86<BR>RH0:Connection: close<BR>RH0:Content-=
Type: text/html; charset=3DISO-8859-1<BR>RH0:<BR>RS0: header 197 content 86=20=
footer 0<BR>Maximum connect burst length: 0<BR><BR>Total: connections 1 requ=
ests 1 replies 1 test-duration 0.197 s<BR><BR>Connection rate: 5.1 conn/s (1=
97.0 ms/conn, &lt;=3D1 concurrent connections)<BR>Connection time [ms]: min=20=
197.0 avg 197.0 max 197.0 median 197.5 stddev 0.0<BR>Connection time [ms]: c=
onnect 97.8<BR>Connection length [replies/conn]: 1.000<BR><BR>Request rate:=20=
5.1 req/s (197.0 ms/req)<BR>Request size [B]: 88.0<BR><BR>Reply rate [replie=
s/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)<BR>Reply time [ms]: res=
ponse 99.2 transfer 0.0<BR>Reply size [B]: header 197.0 content 86.0 footer=20=
0.0 (total 283.0)<BR>Reply status: 1xx=3D0 2xx=3D0 3xx=3D0 4xx=3D1 5xx=3D0<B=
R><BR>CPU time [s]: user 0.06 system 0.14 (user 30.5% system 71.1% total 101=
.5%)<BR>Net I/O: 1.8 KB/s (0.0*10^6 bps)<BR><BR>Errors: total 0 client-timo=20=
0 socket-timo 0 connrefused 0 connreset 0<BR>Errors: fd-unavail 0 addrunavai=
l 0 ftab-full 0 other 0</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV></DIV>
<DIV><FONT face=3DVerdana></FONT>&nbsp;</DIV>
<DIV><FONT face=3DVerdana>&nbsp;</DIV>
<DIV><BR>&nbsp;</DIV></FONT></BODY></HTML>

-------------------------------1070888723--