[httperf] **SPAM**: a question about httperf

Martin Arlitt arlitt@granite.hpl.hp.com
Thu, 27 Feb 2003 07:48:24 -0800 (PST)


Weiyaya

I'm not sure exactly what the problem is.  one thing I did notice is that
two connections were reset:

Errors: total 2 client-timo 0 socket-timo 0 connrefused 0 connreset 2

my recommendation is that you work to eliminate these reset connections
first, and see whether that results in the number of connections and
requests that you expect.  I would use tcpdump to monitor the
communication between your client and server in order to understand what
is going on.

Martin


On Thu, 27 Feb 2003, [GB2312] κѾѾ wrote:

> Dear Sir/Mad,   
> 
>     I am confused by a strange Httperf output as following:
> 
> 
> [wyy79@qoserver bin]$ httperf --hog --port 80 --failure-status 503  --rate 1 --server 166.111.70.100 --timeout 5 --uri /cgi-bin/test.pl --wsess 2,2,1 --burst-len 1   --session-cookies
> httperf --hog --timeout=5 --client=0/1 --server=166.111.70.100 --port=80 --uri=/cgi-bin/test.pl --failure-status=503 --rate=1 --send-buffer=4096 --recv-buffer=16384 --session-cookies --wsess=2,2,1.000
> 
> 
> Maximum connect burst length: 1
> 
> Total: connections 4 requests 6 replies 4 test-duration 2.726 s
> 
> Connection rate: 1.5 conn/s (681.5 ms/conn, <=3 concurrent connections)
> Connection time [ms]: min 313.4 avg 859.1 max 1412.1 median 375.5 stddev 595.8
> Connection time [ms]: connect 0.3
> Connection length [replies/conn]: 1.000
> 
> Request rate: 2.2 req/s (454.4 ms/req)
> Request size [B]: 106.0
> 
> Reply rate [replies/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)
> Reply time [ms]: response 358.5 transfer 0.0
> Reply size [B]: header 197.0 content 584.0 footer 2.0 (total 783.0)
> Reply status: 1xx=0 2xx=0 3xx=0 4xx=0 5xx=4
> 
> CPU time [s]: user 1.07 system 1.66 (user 39.1% system 60.9% total 100.0%)
> Net I/O: 1.3 KB/s (0.0*10^6 bps)
> 
> Errors: total 2 client-timo 0 socket-timo 0 connrefused 0 connreset 2
> Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0
> 
> Session rate [sess/s]: min 0.00 avg 0.73 max 0.00 stddev 0.00 (2/2)
> Session: avg 2.00 connections/session
> Session lifetime [s]: 1.7
> Session failtime [s]: 0.0
> Session length histogram: 0 0 2
> 
> I have two questions:
> 1. I think the number of  requests is 2*2( --wsess 2,2,1). Why in the output do it say 6 (requests 6)?
> 2. In the output, I cann't know how many sessions is sussessful. In the fact, all sessions are failed(5**=4).
> 
>   I will be appreciated if you can help me!!! Thank you!!
> 
> Sincerely,
> 
> 
> 
> Weiyaya
> 
>