[httperf] A strange output

Arlitt, Martin martin.arlitt at hp.com
Fri Mar 30 05:34:08 PST 2007


Hi John

 

Without more details of your test session and your test environment it
is difficult to know exactly what the cause of the problem is.  However,
it appears that for some subset of requests, the server is resetting the
connections.  In some cases this happens before httperf has sent a
request on the connection, and in some cases afterwards.  I suggest
spending some time to determine why the server is resetting these
connections; given the small number of concurrent connections you are
using, I find this behavior a bit surprising.

 

Martin

 

________________________________

From: httperf-bounces at napali.hpl.hp.com
[mailto:httperf-bounces at napali.hpl.hp.com] On Behalf Of John Talbot
Sent: Thursday, March 29, 2007 6:41 PM
To: httperf at napali.hpl.hp.com
Subject: [httperf] A strange output

 

I got the following weird output on an httperf run I did:

It's completely mystifying what might have produced this output - is it
a problem on the target server, a problem on the host running httperf,
or both?

What seems strange to me about it is that it appears that httperf
doesn't retry the connections which were "connreset" here (my until now
experience with httperf has been that reset connections were retried and
resulted in either a successful sessions or in some other type of
error).

But here all the errors are connreset - could someone please enlighten
me as to what might be going on?

Thanks in advance,
- John

________________________________


httperf --timeout=5 --client=0/1 --server=myserver --port=80 --uri=/
--max-connections=2 --max-piped-calls=25 --rate=1 --send-buffer=4096
--recv-buffer=16384 --wsesslog=120,0.000,/urls-list 
Maximum connect burst length: 1 

Total: connections 268 requests 1066 replies 840 test-duration 119.116 s


Connection rate: 2.2 conn/s (444.5 ms/conn, <=2 concurrent connections) 
Connection time [ms]: min 5.3 avg 25.3 max 91.9 median 16.5 stddev 17.9 
Connection time [ms]: connect 2.3 
Connection length [replies/conn]: 4.421 

Request rate: 8.9 req/s (111.7 ms/req) 
Request size [B]: 105.0 

Reply rate [replies/s]: min 0.0 avg 6.4 max 20.0 stddev 9.3 (23 samples)

Reply time [ms]: response 3.3 transfer 0.0 
Reply size [B]: header 387.0 content 54.0 footer 0.0 (total 441.0) 
Reply status: 1xx=0 2xx=840 3xx=0 4xx=0 5xx=0 

CPU time [s]: user 88.62 system 29.72 (user 74.4% system 25.0% total
99.3%) 
Net I/O: 4.0 KB/s (0.0*106 bps) 

Errors: total 226 client-timo 0 socket-timo 0 connrefused 0 connreset
226 
Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0 

Session rate [sess/s]: min 0.00 avg 0.35 max 1.00 stddev 0.47 (42/120) 
Session: avg 4.52 connections/session 
Session lifetime [s]: 0.1 
Session failtime [s]: 0.0 
Session length histogram: 78 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 42 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://napali.hpl.hp.com/pipermail/httperf/attachments/20070330/e456e8a0/attachment.htm


More information about the httperf mailing list