[httperf] connection failed with unexpected error 99

Kyle Campos kyle.campos at gmail.com
Tue Mar 31 12:38:48 PST 2009


On Mar 31, 2009, at 9:31 AM, Arlitt, Martin wrote:

> How many connections are in TIME_WAIT when httperf fails?

Here's what the TCP connections looked around the time of failure:

FIN_WAIT1: 1
TIME_WAIT: 26381
ESTABLISHED: 9

and error code 99 means:

#define	EADDRNOTAVAIL	99	/* Cannot assign requested address */

So this might be the cause. At least a good place to start.

-Kyle

>
>> -----Original Message-----
>> From: Kyle Campos [mailto:kyle.campos at gmail.com]
>> Sent: Tuesday, March 31, 2009 9:19 AM
>> To: Arlitt, Martin
>> Cc: httperf at linux.hpl.hp.com
>> Subject: Re: [httperf] connection failed with unexpected error 99
>>
>> I've received FD errors before and they looked different. If on the
>> driver machine httperf would record in the Errors: fd-unavail  
>> section.
>> If on the SUT then I'd get some system errors on that side, but I'm
>> not seeing either of those.
>>
>> -Kyle
>>
>> On Mar 31, 2009, at 8:39 AM, Arlitt, Martin wrote:
>>
>>> Hi Kyle
>>>
>>> I believe I've had a similar error message when I exhausted the
>>> available file descriptors (e.g., too many connections in
>>> TIME_WAIT).  If you think that might be the problem you are
>>> experiencing, please check the httperf mail archive for information
>>> on that.
>>>
>>> Martin
>>>
>>>> -----Original Message-----
>>>> From: httperf-bounces at napali.hpl.hp.com [mailto:httperf-
>>>> bounces at napali.hpl.hp.com] On Behalf Of Kyle Campos
>>>> Sent: Tuesday, March 31, 2009 8:30 AM
>>>> To: httperf at napali.hpl.hp.com
>>>> Subject: [httperf] connection failed with unexpected error 99
>>>>
>>>> Hi,
>>>>
>>>> I'm running into this error when I get to a very specific rate:
>>>>
>>>> $ httperf --server 192.168.24.53 --port 8080 --timeout 10 -- 
>>>> wsesslog
>>>> 48000,1,data.load --rate 480
>>>> $ httperf: connection failed with unexpected error 99
>>>>
>>>> [1]+  Segmentation fault
>>>>
>>>> And this error occurs somewhere towards the end of the test. My
>>>> driving box has plenty of memory left. Googling this error hasn't
>>>> shown me much of anything. A rate of 440 passes with flying colors.
>>>> No
>>>> errors are seen on the SUT.
>>>>
>>>> Anyone ran into this before?
>>>>
>>>> -Kyle
>>>> _______________________________________________
>>>> httperf mailing list
>>>> httperf at linux.hpl.hp.com
>>>> http://www.hpl.hp.com/hosted/linux/mail-archives/httperf/
>



More information about the httperf mailing list