[httperf] problem with httperf

Tim Terrill TTerrill at synacor.com
Tue Jan 29 06:06:38 PST 2013


Luca,

>From your latest output, you do have an issue with file descriptors.  This link (http://gom-jabbar.org/articles/2009/02/04/httperf-and-file-descriptors) will help you fix that problem.  I recommend doing that and then re-run your test to see what happens.

Tim

Senior Systems Performance Engineer
Synacor, Inc.
40 La Riviere Drive, Suite 300
Buffalo, NY 14202
716-362-3444

From: Vikash Kumar <vikash.kumar at oneconvergence.com<mailto:vikash.kumar at oneconvergence.com>>
Date: Monday, January 28, 2013 11:05 PM
To: "fane.luca at libero.it<mailto:fane.luca at libero.it>" <fane.luca at libero.it<mailto:fane.luca at libero.it>>
Cc: "httperf at linux.hpl.hp.com<mailto:httperf at linux.hpl.hp.com>" <httperf at linux.hpl.hp.com<mailto:httperf at linux.hpl.hp.com>>
Subject: Re: Re: [httperf] problem with httperf

Luca,

      The reply rate seems fine. I can say it's OK. Their is one possibility why it's hanging is:

     May be for few connections, client is waiting for the response from server side. Httperf client wait infinitely , if it doesn't get response from the other side. See the manual page of "httperf". But if it had been the case, the reply rate should have gone to 0.0 and which say this is not the case. Anyway it will be gud if u verify it once more.

    I don't think their is issue with "file descriptor" or "no of sockets". U must check once log of ur server.

   I will suggest u to have wireshark capture on both client and server side and analyze what really going on. It will save ur time and effort.


Thanx



On Mon, Jan 28, 2013 at 3:29 PM, fane.luca at libero.it<mailto:fane.luca at libero.it> <fane.luca at libero.it<mailto:fane.luca at libero.it>> wrote:

thanks to answer,I've attend for 1 hour, i add -v :

"
sudo httperf --server localhost --port 80 --uri /image/Stark10.jpg --rate 300 --num-conn 100000 --num-call 10 --hog -v
httperf --verbose --hog --client=0/1 --server=localhost --port=80 --uri=/image/Stark10.jpg --rate=300 --send-buffer=4096 --recv-buffer=16384 --num-conns=100000 --num-calls=10
httperf: warning: open file limit > FD_SETSIZE; limiting max. # of open files to FD_SETSIZE
httperf: maximum number of open descriptors = 1024
reply-rate = 2987.3
reply-rate = 3000.6
reply-rate = 3000.2
reply-rate = 3000.8
reply-rate = 2999.4
reply-rate = 2999.2
reply-rate = 2999.4
reply-rate = 2999.8
reply-rate = 2999.6
reply-rate = 3000.4
reply-rate = 2999.8
reply-rate = 2980.4
reply-rate = 2999.4
reply-rate = 3012.6
reply-rate = 3004.0
reply-rate = 2999.6
reply-rate = 3000.0
reply-rate = 3000.8
reply-rate = 2999.0
reply-rate = 2963.4
reply-rate = 3037.4
reply-rate = 2998.0
reply-rate = 2978.0
reply-rate = 3020.0
reply-rate = 2999.4
reply-rate = 3002.4
reply-rate = 3000.8
reply-rate = 2999.8
reply-rate = 2998.0
reply-rate = 3001.2
reply-rate = 2996.0
reply-rate = 2978.8


^CMaximum connect burst length: 9
Maximum connect burst length: 9
^CMaximum connect burst length: 9

Maximum connect burst length: 9


"

I think that the problem is arround number of maximum TCP ports or file descriptors;


----Messaggio originale----
Da: vikash.kumar at oneconvergence.com<mailto:vikash.kumar at oneconvergence.com>
Data: 28/01/2013 4.54
A: "fane.luca at libero.it<mailto:fane.luca at libero.it>"<fane.luca at libero.it<mailto:fane.luca at libero.it>>
Cc: <httperf at linux.hpl.hp.com<mailto:httperf at linux.hpl.hp.com>>
Ogg: Re: [httperf] problem with httperf


luca,

    Your test will take more than 7-8 minute to complete. Are u waiting for this much time before u press Ctrl-C?

    What is the reply rate u re achieving ? Append '-v' option in the command. U will get the reply rate.

    Better capture the tcpdump on both side. Next time please attach ur dump file.

Thanks



On Mon, Jan 28, 2013 at 12:18 AM, fane.luca at libero.it<mailto:fane.luca at libero.it> <fane.luca at libero.it<mailto:fane.luca at libero.it>> wrote:

Hi!

I've a problem with httperf, when i test my http server :

"sudo httperf --server localhost --port 80 --uri /image/Stark10.jpg --rate 300 --num-conn 100000 --num-call 10 --hog"






httperf don't stop and if I push crtl c to close him I've de answer:

CMaximum connect burst length: 4.

It's a bug?


Thanks!



_______________________________________________
httperf mailing list
httperf at linux.hpl.hp.com<mailto:httperf at linux.hpl.hp.com>
http://www.hpl.hp.com/hosted/linux/mail-archives/httperf/






-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://napali.hpl.hp.com/pipermail/httperf/attachments/20130129/94aac1c4/attachment-0001.htm


More information about the httperf mailing list