[Gc] GC, Solaris and threads

Emmanuel Stapf [ES] manus at eiffel.com
Fri Jan 13 09:52:56 PST 2006

> I found this problem, it was that I needed to define 
> GC_SOLARIS_PTHREAD in order to get the redirection when 
> including the GC header file. However it does not quite work 
> yet, but I'll have to investigate more.

I still cannot figure out why it does not work, so I decided to run `gctest' to
see if it would work or not and as far as I can tell (see below) it does not work.

amsterdam [Manu] : ./gctest 
GC Warning: Large stack limit(10485760): only scanning 8 MB
Apparently failed to mark form some function arguments.
Perhaps GC_push_regs was configured incorrectly?
Test failed
Segmentation fault (core dumped)

The GC Warning can be removed if I manually the stack size to 7MB, but the error
is not removed.

Can someone help me figure out if there is something in my configuration which is
not supported by version 6.6 of the GC?

- Solaris 10 on AMD64
- use Sun C compiler with no optimizations and debug information `cc -g' and
generating 32 bits binary.
- compiled GC with `configure --enable-threads=posix'

I've also tried to compile with `gcc' and/or without `--enable-threads=posix' but
I always get the same error.

The version numbers of the C compilers I'm using:
- cc: Sun C 5.7 Patch 117837-05 2005/07/19
- gcc = 3.4.3

Thanks for your help,

More information about the Gc mailing list