[Gc] Has anyone tried the GC on Nokia 770, N800 or arm qemu ?

Boehm, Hans hans.boehm at hp.com
Thu Jan 25 11:18:56 PST 2007

I don't think there are any exit() calls in the source that aren't
preceded by some indication of an error.  Can you run a debugger and set
a breakpoint in exit()?  I'm not sure what the "245" indicates, but if
it's the argument to exit(), this is even more mysterious.

You might also set a breakpoint in abort(), just in case that's somehow
getting mishandled.


> -----Original Message-----
> From: Stephane Epardaud [mailto:Stephane.Epardaud at sophia.inria.fr] 
> Sent: Thursday, January 25, 2007 7:58 AM
> To: Boehm, Hans
> Cc: gc at napali.hpl.hp.com
> Subject: Re: [Gc] Has anyone tried the GC on Nokia 770, N800 
> or arm qemu ?
> Boehm, Hans wrote:
> > My only direct experience is a native build on a Linksys 
> NSLU2.  That 
> > has an ARM processors and works.  But that's a very different 
> > environment.  Posting a stack trace might get you further ...
> The problem is I don't get any stack. I've traced down the 
> problem in the gc7a somewhere in 
> alloc.c:GC_try_to_collect_inner() which is called by GC_INIT().
> The gctest just exits with an error, no log and no stack trace.
> When calling gctest with GC_PRINT_STATS=1 I get as far as:
> Increasing heap size by 65536 after 0 allocated bytes 
> Initiating full world-stop collection 1 after 0 allocd bytes
> --> Marking for collection 1 after 0 allocd bytes
> but GC_INIT never returns.

More information about the Gc mailing list