[Gc] GC_gww_read_dirty unexpectedly failed

Hans Boehm Hans.Boehm at hp.com
Sun May 17 08:03:47 PDT 2009

I'm just running the 32 bit, static library, gctest, compiled with
VS 2005, on an XP 64 box.  GWW_VDB is no longer defined.  Otherwise,
my version should be similar to the trunk.

I tried running the excutable on an XP32 box, with similar results.
It would be interesting to know whether you can reproduce the problem
under similar conditions.



On Sun, 17 May 2009, Ivan Maidanski wrote:

> Hi!
> "Boehm, Hans" <hans.boehm at hp.com> wrote:
>> I'm actually still trying to track down some other problems inthis area.  I'm still not having a lot of luck with incremental GC on my Windows machine.  I was trying to to track down the very intermittent failures with GetWriteWatch, and tried turning it off.  But the MPROTECT_VDB version currently seems to reliably deadlock in fairly opaque ways, at least on a dual core machine.  Unfortunately, I'm far less efficient debugging this stuff on Windows than Linux ...
> I've never run into this trouble (deadlock). My test box is the same (2 cores). Do You have any test showing it?
>> Hans
> Bye.

More information about the Gc mailing list