[Gc] hangs on malloc

Ian Martins ianxm at jhu.edu
Wed Jul 28 11:22:56 PDT 2010

Hello.  I'm having trouble with nekovm (https://nekovm.org) which uses
libgc.  There is no trouble when it runs directly, but it hangs when it
runs as an apache2 module.  I traced the place where it hangs to a
GC_generic_malloc call.  It hangs at the same place every time.  I've
got the same behavior on two machines (different hardware, same os:
ubuntu, 32 bit, latest)  I tried some different versions of libgc (6.4,
6.8, 7.1, 7.2alpha4) but got the same result.  This is the stack when it
hangs (using ver 7.2alpha4):

First call at the top:
               GC_generic_malloc(18, 1)
malloc.c:166.  GC_generic_malloc_inner(18, 1)
malloc.c:126.  GC_allocobj(18, 1)
alloc.c:1299.  GC_collect_or_expand(1, FALSE, FALSE)
alloc.c:1212.  GC_try_to_collect_inner()
alloc.c:436.   GC_stopped_mark()
alloc.c:584.   STOP_WORLD()

It doesn't return from STOP_WORLD.  Stays there for days.
Please let me know what additional info that may help or of anything I
can try.


More information about the Gc mailing list