[Gc] GC_get_stack_base() fallure on Mac OS X 10.6.7

Hans Aberg haberg-1 at telia.com
Sun May 22 12:33:57 PDT 2011

On 22 May 2011, at 20:59, Ivan Maidanski wrote:

>>> I've run ./configure (without any options) on iPhone and it generated
>> config.h with GC_DARWIN_THREADS on, so multi-threading is on by default.
>> It is the same on Mac OS X 10.6.7 (another OS). I also compiled it, and it
>> worked with guile-2.0.1, though I did not recompile the latter.
> The later - you mean the latest GC release - v7.2alpha4, right? If yes then it is ok as this has been fixed only recently (as I've already said).

No - I first tried all kind of variations using bdwgc-7_2alpha5-20110107, also recompiling guile-2.0.1, and nothing worked - the guile error was always
  Failed to get stack base for current thread.
which happens when its scm_init_guile() calls GC_get_stack_base(). This is the first guile version that calls GC_get_stack_base().

I then used the CVS version of GC, as you suggested, using
  ./configure --enable-threads=posix && make
which worked. I think it might have worked without recompiling guile-2.0.1, so it would then call GC dynamically.

I then tried
  ./configure && make
and that worked, too, though I did not recompile guile-2.0.1.

In short, the current GC snapshot does not work - a new one would.


More information about the Gc mailing list