[Gc] Naming of the "disclaim" API

Petter Urkedal urkedal at nbi.dk
Sat Oct 1 03:04:47 PDT 2011

On 2011-10-01, Ivan Maidanski wrote:
> May be, it would be good to rename 'disclaim' words into something more self-explaining word?

Hi Ivan, I CC this to the list in case someone has suggestions.

The logic behind the word "disclaim" is that the patch in question adds
a call-back invoked before an object is reclaimed.  This call-back is
responsible for either making sure that the object is no longer needed.
That's what I mean by "disclaiming" the object.  The call-back may also
refuse to "disclaim" the object, in case it has been reused since the
last collection.  Any better suggestions?  The current API can be seen at

More information about the Gc mailing list