[Gc] Re[2]: Powerpc/m68k issue running test_stack

Pavel Raiskup praiskup at redhat.com
Wed Dec 5 23:29:42 PST 2012

On Wed, 2012-12-05 at 18:08 +0000, Thorsten Glaser wrote:
> Pavel Raiskup dixit:
> >I was unable to find here in mail archives system (glibc, kernel, ..)
> >requirements for supporting this test on PowerPC - thus I'm not sure how
> >to fix/help you regarding this issue.
> Can you try with this patch applied for more debugging?

Oh, of course.  I should have put here the VERBOSE output even before.
It has still the same non-deterministic behavior as was described before -
it fails always after different number of steps, sometimes it gets into
infinite loop.

I'm attaching tarball with several runs of the test/test_stack program.

Ok, could you point me where should I look?  I have tried the
"compare_and_swap", "test_and_set", "fetch_and_add" low-level calls and
they works well with 5+ threads.

Note, I don't have the access to the same machine as before at the moment,
I need to make an reservation and it may take even days -> attached logs
are from another powerpc machine with same HW (Fedora 16):

  $ rpm -q automake autoconf gcc glibc

  $ head /proc/cpuinfo
  processor       : 0
  cpu             : POWER7 (architected), altivec supported
  clock           : 3550.000000MHz
  revision        : 2.1 (pvr 003f 0201)

  processor       : 1
  cpu             : POWER7 (architected), altivec supported
  clock           : 3550.000000MHz
  revision        : 2.1 (pvr 003f 0201)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: test_stack.tar.gz
Type: application/x-compressed-tar
Size: 1276 bytes
Desc: not available
Url : https://napali.hpl.hp.com/pipermail/gc/attachments/20121206/2acda640/test_stack.tar.bin

More information about the Gc mailing list