[Gc] Re[6]: Powerpc/m68k issue running test_stack

Pavel Raiskup praiskup at redhat.com
Mon Dec 17 06:34:30 PST 2012

On Mon, 2012-12-10 at 13:19 +0400, Ivan Maidanski wrote:
Hi Ivan,

> Ok, try another tests (master branch):
> 1. -D AO_PREFER_GENERALIZED - if it does not help, define it
> permanently until we fix the bug

This does not help.  OK -> I've set it permanent for now.

> 2. temporarily replace all occurrences of ..._release and ..._acquire
> with ..._full in atomic_ops_malloc.c, ops_stack.c, ops_stack.h

Well, I tried to use _full() brothers of these calls as you said but it
gives me still the same result -> abort() with coredump.  Other tests
work fine even now.  I'm not sure what exactly should I switch to _full()
-> so I redefined also the stack API the hard way :) %s/_acquire/_full/.
Applied patch is attached.  It seems that the problem is somewhere else.
Hopefully, I'm not doing anything bad until now.

Thanks for cooperation,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: libatomic.patch
Type: text/x-patch
Size: 9341 bytes
Desc: not available
Url : https://napali.hpl.hp.com/pipermail/gc/attachments/20121217/a3591dd4/libatomic.bin

More information about the Gc mailing list