[Gc] gc make fail on Solaris 10 x86_64 with gcc-3.* & -m64 option

Kiyoshi KANAZAWA yoi_no_myoujou at yahoo.co.jp
Sun Mar 25 03:42:58 PST 2012


I tried to build 64bits gc-7.1 on Solaris 10 x86_64. but failed with message:
                 from ./include/private/gc_locks.h:30,
                 from ./include/private/gc_priv.h:85,
                 from alloc.c:19:
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:9:23: xmmintrin.h: No such file or directory
In file included from libatomic_ops/src/atomic_ops/sysdeps/gcc/x86_64.h:37,
                 from libatomic_ops/src/atomic_ops.h:197,
                 from ./include/private/gc_locks.h:30,
                 from ./include/private/gc_priv.h:85,
                 from alloc.c:19:
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:10: error: syntax error before "double_ptr_storage"
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:10: warning: data definition has no type or storage class
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:30: error: syntax error before "double_ptr_storage"
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:30: warning: no semicolon at end of struct or union
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:32: error: syntax error before '}' token
libatomic_ops/src/atomic_ops/sysdeps/gcc/../standard_ao_double_t.h:32: warning: data definition has no type or storage class
make[1]: *** [alloc.lo] Error 1

This occurs with gcc-3.4.3 & -m64 option.
Passes with gcc-4.4.7 & -m64.
I tried gc-7.2alpha6 but had the same result.
I'm afraid algorithm to find "GCC_PATH/lib/gcc/i386-pc-solaris-version/GCC_VERSION/install-tools/include" depends on gcc version.

gcc-3.4.3 is included in Solaris10 distribution.
Many GNU softwares, including gc, are required to build newer gcc.
(I once built them with -m32, and now trying with -m64)

Best regards,

--- Kiyoshi <yoi_no_myoujou at yahoo.co.jp>

More information about the Gc mailing list