[httperf] fd-unavail non-null

Sylvain GENEVES Sylvain.Geneves at inrialpes.fr
Tue Aug 31 13:39:24 PDT 2010


I run httperf on linux using --wsesslog=45371,0.000,/my_sessions_path
--rate=2000 and --timeout=3 for a big overload test.
what i don't understand is that it tells me fd-unavail is non-null (tens
of thousands actually), though i've dramatically increased the max open
files limit to 786762. I've tried to increase it to 5000000, but the
results are the same : there're still the fd-unavail errors...

I've had a doubt, but it appears that the per-process max open files limit
on linux is shown by "ulimit -n", so i first modified system-wide settings
(through sysctl), then in PAM (/etc/security/limits.conf), then in ulimit.

I've modified the code to count EINVAL errors in a separate way, thus
fd-unavail only counts EMFILE errors, no change...

does someone know what's going on?
also, i don't know if it's related, but i see a strange behaviour when i
launch multiple instances of httperf :
 - they don't finish at the same time (some instances finish tens of
minutes later than the first one)
 - in the end the remaining instances should be doing 2000sessions/sec,
but instead they do ~2requests/sec : the server is so idle i can check it
live with tcpdump...


More information about the httperf mailing list